Flector

Feed Pauser

Очень часто случается, что после публикации записи вы вдруг замечаете, что допустили в ней либо орфографическую ошибку, либо ошиблись в написании ссылки, либо еще что не досмотрели. Быстрое редактирование записи исправит недочеты, только вот некорректный текст в RSS ленте уже мог уйти в различные RSS читалки. Вряд ли возникнут проблемы с Google Reader, он зачастую публикует записи с ощутимой задержкой, но вот некоторые реактивные читалки чуть ли не в момент публикации забирают к себе запись из ленты. В качестве примера могу привести настройку Windows Live Writer для работы с блогом - он, чтобы правильно определить стиль, используемый в блоге, публикует и тут же удаляет временную запись. В блоге эта запись видна не больше 10 секунд, только вот Яндекс.Ленте этого вполне хватает, чтобы забрать ее к себе. Плагин Feed Pauser дает возможность задать задержку, с которой будут публиковаться записи в RSS ленте, а также дает возможность вообще исключить определенный пост из вашего фида.

Скачиваем плагин с его домашней страницы и устанавливаем его:

1. Распаковываем архив.

2. Копируем папку feed-pauser в /wp-content/plugins/.

3. Заходим в админку блога на вкладку "Плагины" и активируем плагин.

Даже после активации плагина он еще не работает. Чтобы включить его вы должны зайти в "Записи\Feed Pauser", указать там время задержки публикации записи в фиде и обязательно поставить галку на "Activate Feed Pauser". После сохранения этих настроек плагин начнет работать и записи в фиде будут публиковаться с указанной вами задержкой.

Также плагин реализует возможность исключить любой пост из вашей RSS ленты. Для этого при редактировании записи поставьте галку на "Hide In Feed":

Хочу заметить, что если запретите публиковать запись в фиде, то она не будет опубликована не только в основной ленте блога, но и во всех остальных (то есть ее не будет ни в ленте по рубрикам, ни по тегам и т.д.).

 

Автор плагина: Keith Dsouza
Страница плагина: http://wordpress.org/extend/plugins/feed-pauser/
Рассматриваемая версия: 1.0 от 15.04.2009
Совместимость с версией WordPress: 2.5 и выше.

Понравился пост? Подпишись на обновления по Обновления блога по RSSRSS или Обновления блога на TwitterTwitter !

Комментарии (всего 5 комментариев)

Написать комментарий

(обязательно)

(обязательно, не публикуется)

Для вставки кода используйте кнопку "Код", по умолчанию используется синтаксис подсветки языка "php", вы можете поменять его на любой другой поддерживаемый GeSHi язык, например "javascript", "css", "html4strict", "sql" и тд. Используйте предпросмотр!
 


Подписаться на уведомления без комментирования.


Пингбэки и Трекбэки (всего 2 ссылки)